GothicShop



Details
Region:
GothicShop
Grid:
freedomgrid.world:8002
Rating:
General
Category:
Freebies
Added by :
McCreadyGhost
Created :
4 years ago
Traffic Rank:
809th
Avatars in Region:
0




Status
Region Status:
Online
Avatars in region:
0
Last checked:
29 minutes ago
HyperGrid:

Visit this region:
Hop V3HG HG Local Grid

Recent avatar traffic
Region status history ⇒

Upcoming Events
No events

Reviews (11)
Overall Rating:
Nico Kalani So much consternation and questioning about what viewers are allowed at GothicShop. Scheesh. It's so simple. Look at the name people. Gothic! If your viewer is not German and was not created in the middle ages, then you are BANNED. BANNED I tell you. You are BANNED!
monic korobase acces refusé !!! pourquoi .?
CindaWindlow Visited today using FS 6.5.6. Nicely done. No issues with my viewer. Was a little laggy in places, but that is not unusual.

Region Comments

mmmm was there today 10-27-22. No problems. But my way of thinking is that I never need the newest FS. Like Kyle I used the FS 6.02. No problems. I could get there without any probs
like(0)
The GothicShop only allows one single Firestorm version. And that's either the version that was the most up-to-date when the sim was last worked on or the version which the sim owner used when the sim was last worked on.

And the sim has probably remained untouched ever since its launch 2 years ago. This means that the viewer whitelist has not been changed since long before the release of Firestorm 6.4.12.

Thus, the only viewer allowed on this sim is either Firestorm 6.0.2 or Firestorm 6.3.9. I'm leaning more towards 6.0.2 because that was the only Firestorm version that CMFreedom allowed back in the day. Even if you should manage to dig up a copy of Firestorm 6.0.2, many of you will barely be able to use it because it was the last version without BoM.
like(0)
What viewer is not banned? perhaps this is a very private region?
like(0)
Tell us what Viewer is Not Banned
like(2)